ひとり社内SEと情シスを応援します

Cisco 841MJ でフレッツに接続する

Cisco製ルータの841MJでフレッツに接続し、インターネットが使えるようにします。
なお、標準のGUIは使わずにCUIで設定します。

用意するもの

C841M-4X-JSEC/K9 ×1台。

iOSが使えるCiscoルータなのに新品でこの値段。昔はヤフオクで中古の機器を仕入れていたので、それと比べるといい時代ですね。

設定のポイント

  • ルータのIPアドレスは 192.168.10.254 としてvlan1に割り当てます。
  • vlanの設定は出荷時から変更しません。
  • 本体のLANポートは0~3がLAN側(PCと接続)、4がWAN側(ONUと接続)、5は使いません。
  • Cisco Configuration Professional ExpressというGUIは使わないのであらかじめ削除(アンインストール方法はここを参照)
  • DHCPサーバとして利用 割り当てるIPは192.168.10.1~192.168.10.20
  • DNSサーバとして利用
  • SSHを有効にする(アクセス制限は特につけません)
  • LAN側の機器からインターネットが使えるようにする
  • FirewallとしてCBACを使う
  • サーバは公開しない
  • 回線:フレッツ光
  • プロバイダ:なんでもOK。固定IPでも動的IPでも設定上の違いはありません。

コンフィグ

プロバイダのIDとパスワードはお使いのものに変更してください。

hostname home
!
ip dhcp excluded-address 192.168.10.21 192.168.10.254
!
ip dhcp pool dhcp-pool
 import all
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.254 
 dns-server 192.168.10.254 
 lease 0 2
!
!
!         
ip inspect name CBAC tcp
ip inspect name CBAC udp
ip inspect name CBAC icmp
ip cef    
no ipv6 cef
!         
!                
!
!         
redundancy
!         
!         
!         
!         
no cdp run
!         
!         
!         
interface GigabitEthernet0/0
 no ip address
!         
interface GigabitEthernet0/1
 no ip address
!         
interface GigabitEthernet0/2
 no ip address
!         
interface GigabitEthernet0/3
 no ip address
!         
interface GigabitEthernet0/4
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!         
interface GigabitEthernet0/5
 no ip address
 duplex auto
 speed auto
!         
interface Vlan1
 ip address 192.168.10.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1414
!         
interface Dialer1
 mtu 1454 
 ip address negotiated
 ip nat outside
 ip inspect CBAC out
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp mtu adaptive
 ppp authentication chap callin
 ppp chap hostname プロバイダのID
 ppp chap password 0 プロバイダのパスワード
 ppp ipcp dns request accept
 ppp ipcp route default
 no cdp enable
!         
ip forward-protocol nd
no ip http server
no ip http secure-server
!         
!         
ip dns server
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!         
ip access-list extended ssh
 permit ip any any
!         
dialer-list 1 protocol ip permit
!         
!         
!         
!         
line con 0
 login local
 no modem enable
line vty 0 4
 access-class ssh in
 privilege level 15
 login local
 transport input ssh
line vty 5 15
 access-class ssh in
 privilege level 15
 login local
 transport input ssh
!         
scheduler allocate 20000 1000
!         
end

関連記事

カテゴリー